Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-36912

M1M3 CSC cannot be started when heartbeats aren't bypassed in GIS

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • ts_main_telescope

    Description

      M1M3 CSC cannot be started with heartbeat not bypassed in IS. The problem is probably caused by this sequence:

      1. CSC is commanded to start
      2. GIS doesn't receive heartbeat, so it engage (disable M1M3 SS)
      3. CSC startup fails, as GIS signal M1M3 isn't ready

      Attachments

        Activity

          pkubanek Petr Kubanek added a comment -

          This was fixed in CSC C. I am looking on why interlock power status isn't updated, looks like CSC isn't processing DigitalInput/DigitalOutput data.

          pkubanek Petr Kubanek added a comment - This was fixed in CSC C. I am looking on why interlock power status isn't updated, looks like CSC isn't processing DigitalInput/DigitalOutput data.
          pkubanek Petr Kubanek added a comment - Please see PR: https://github.com/lsst-ts/ts_m1m3support/pull/112
          pkubanek Petr Kubanek added a comment -

          Fixed CI, merged.

          pkubanek Petr Kubanek added a comment - Fixed CI, merged.

          People

            pkubanek Petr Kubanek
            pkubanek Petr Kubanek
            Dave Mills
            Dave Mills, Felipe Daruich, Petr Kubanek, Roberto Tighe
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Jenkins

                No builds found.