Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3705

Update ndarray to use current numpy API

    Details

    • Type: Improvement
    • Status: Done
    • Priority: Minor
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ndarray
    • Labels:
      None
    • Templates:
    • Story Points:
      1
    • Sprint:
      DRP F17-2
    • Team:
      Data Release Production

      Description

      When we build software that uses SWIG and ndarray we get warning "Using deprecated NumPy API. Please update ndarray so we are using the current API.

      If in the interim you want to suppress the warnings, I suggest issuing a separate ticket for that. I have mixed feelings about suppressing the warnings. On the one hand false warnings do make it harder to spot real problems. On the other hand these warnings are not very numerous (building afw only results in 8 of them) and so are fairly easy to ignore.

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  pschella Pim Schellart [X] (Inactive)
                  Reporter:
                  rowen Russell Owen
                  Reviewers:
                  Jim Bosch
                  Watchers:
                  Jim Bosch, John Parejko, John Swinbank, Krzysztof Findeisen, Pim Schellart [X] (Inactive), Russell Owen
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Summary Panel