Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-37811

Create updated LATISS calibrations with parallel overscan enabled

    XMLWordPrintable

Details

    • Improvement
    • Status: Done
    • Resolution: Done
    • None
    • None
    • 10
    • Data Release Production

    Attachments

      1. coadd_patterns.png
        coadd_patterns.png
        6.49 MB
      2. cpVerifyBias-v2.ipynb
        74 kB
      3. cpVerifyDark-v2.ipynb
        68 kB
      4. cpVerifyFlat-BG40-v2.ipynb
        191 kB
      5. cpVerifyFlat-OG550-v2.ipynb
        186 kB
      6. cpVerifyFlat-SDSSg-v2.ipynb
        283 kB
      7. cpVerifyFlat-SDSSi-v2.ipynb
        191 kB
      8. cpVerifyFlat-SDSSr-v2.ipynb
        324 kB
      9. install.log
        10 kB
      10. LATISS_bias_2022112200398_u_laurenma_DM-37811.png
        LATISS_bias_2022112200398_u_laurenma_DM-37811.png
        1.56 MB
      11. LATISS_bias_DM-37811.png
        LATISS_bias_DM-37811.png
        396 kB
      12. LATISS_postISRCCD_2022112200398_u_czw_testing.png
        LATISS_postISRCCD_2022112200398_u_czw_testing.png
        878 kB
      13. LATISS_postISRCCD_2022112200398_u_laurenma_DM-37805.png
        LATISS_postISRCCD_2022112200398_u_laurenma_DM-37805.png
        1.78 MB
      14. LATISS_postISRCCD_2022112200398_u_laurenma_DM-37811.png
        LATISS_postISRCCD_2022112200398_u_laurenma_DM-37811.png
        2.06 MB
      15. work.20230207.log
        4 kB
      16. work.log
        11 kB

      Issue Links

        Activity

          The goal of this ticket was to see if the parallel overscan improvements could fix the image quality issues that were reported by lauren; the attached coadd_patterns.png shows the amp-to-amp features caused by mismatch between the science data and the bias calibration.  The quality of the postISRCCD images that went into this coadd can be seen in LATISS_postISRCCD_2022112200398_u_laurenma_DM-37805.png, with an initial pass with parallel overscan enabled in LATISS_postISRCCD_2022112200398_u_laurenma_DM-37811.png.  Unfortunately, the calibs that went into this reduction used the w05 }}weekly, instead of the newly updated version of {{ip_isr (my mistake), but it shows the problems with the older code: the postISRCCD shows severe oversubtraction, and the associated bias ( LATISS_bias_[...]DM-37811.png) shows that two amplifiers have clearly not been corrected consistent with the other amplifiers.  Running with the correct ip_isr yields LATISS_postISRCCD[...]czw_testing.png, which is a much cleaner image.  The final bias is shown in LATISS_bias_DM-37811.png.

          As parallel overscan hasn't been enabled globally for LATISS, I have built calibrations into a separate user CALIBRATION collection for continued testing before that switch is done:  u/czw/DM-37811/parOStest.20230202a/calib .  This collection contains a bias, dark, and flats for gri, and should be usable with the updated 65mm filters and for the v26 sequencer.

           

           

          czw Christopher Waters added a comment - The goal of this ticket was to see if the parallel overscan improvements could fix the image quality issues that were reported by lauren ; the attached coadd_patterns.png shows the amp-to-amp features caused by mismatch between the science data and the bias calibration.  The quality of the postISRCCD images that went into this coadd can be seen in LATISS_postISRCCD_2022112200398_u_laurenma_ DM-37805 .png , with an initial pass with parallel overscan enabled in LATISS_postISRCCD_2022112200398_u_laurenma_ DM-37811 .png .  Unfortunately, the calibs that went into this reduction used the w05 }}weekly, instead of the newly updated version of {{ip_isr (my mistake), but it shows the problems with the older code: the postISRCCD shows severe oversubtraction, and the associated bias ( LATISS_bias_ [...] DM-37811 .png ) shows that two amplifiers have clearly not been corrected consistent with the other amplifiers.  Running with the correct ip_isr yields LATISS_postISRCCD [...] czw_testing.png , which is a much cleaner image.  The final bias is shown in LATISS_bias_ DM-37811 .png . As parallel overscan hasn't been enabled globally for LATISS, I have built calibrations into a separate user CALIBRATION collection for continued testing before that switch is done:  u/czw/ DM-37811 /parOStest.20230202a/calib .  This collection contains a bias, dark, and flats for gri, and should be usable with the updated 65mm filters and for the v26 sequencer.    

          These calibrations have now been distributed to the main USDF repository and the summit.  Marking this ticket done.

          czw Christopher Waters added a comment - These calibrations have now been distributed to the main USDF repository and the summit.  Marking this ticket done.

          People

            czw Christopher Waters
            czw Christopher Waters
            Christopher Waters, Eli Rykoff, Huan Lin, Lauren MacArthur
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Jenkins

                No builds found.