Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3844

Add tutorial-level documentation for ctrl_pool

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ctrl_pool
    • Labels:
    • Story Points:
      4
    • Team:
      Data Release Production

      Description

      The new ctrl_pool package (port of hscPipeBase) has no tutorial-level documentation, making it hard to figure out how to start using the package.

      Unfortunately, I think only Paul Price is qualified to write it directly, though it may make sense to have someone unfamiliar write it while bugging Paul a lot, both to transfer the knowledge and target the documentation better.

        Attachments

          Issue Links

            Activity

            price Paul Price added a comment -
            swinbank John Swinbank added a comment - - edited

            There's already a demo script in ctrl_pool: first step here is to look at that and figure out if it's adequate, and make sure it's properly signposted. We should then also get sign-off from NCSA to make sure they are ready to accept responsibility for ctrl_pool.

            yusra Yusra AlSayyad added a comment -

            This was fulfilled by https://dmtn-023.lsst.io/ I think.

            tjenness Tim Jenness added a comment -

            Marked as a duplicate of DM-6596.


              People

              • Assignee:
                Unassigned
                Reporter:
                jbosch Jim Bosch
                Watchers:
                Jim Bosch, John Swinbank, Paul Price, Tim Jenness, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel