Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-4323

Replace fitsthumb in obs_subaru (port HSC-1196)

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw, obs_subaru
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      Science Pipelines DM-W16-3
    • Team:
      Data Release Production

      Description

      fitsthumb is now obsolete; all the functionality we need is available in afw. Further, we want to drop it as a dependency to make the job of integrating obs_subaru with CI easier.

        Attachments

          Issue Links

            Activity

            Hide
            swinbank John Swinbank added a comment -

            This also covers work on HSC-1094 (it's rendered obsolete by HSC-1196, but I'll pull it over to preserve history).

            Show
            swinbank John Swinbank added a comment - This also covers work on HSC-1094 (it's rendered obsolete by HSC-1196, but I'll pull it over to preserve history).
            Hide
            swinbank John Swinbank added a comment -

            The afw part of this work was already covered on DM-2436.

            Show
            swinbank John Swinbank added a comment - The afw part of this work was already covered on DM-2436 .
            Hide
            swinbank John Swinbank added a comment -

            Hey Nate – could you take a look at this, please?

            Show
            swinbank John Swinbank added a comment - Hey Nate – could you take a look at this, please?
            Hide
            nlust Nate Lust added a comment -

            I know this is probably not your change, but I question the choice of binned as the variable name at line https://github.com/lsst/obs_subaru/commit/f5fb626d2f40e647766c3ce09d93e9e3f597b8ed#diff-a371bdde1303aa2ed64bfec4eefc16e8R410 especially as it follows the variable binning. I think something like binnedImage or something would be more appropriate, but I don't think changing it is a requirement for merging. Other than that I think it looks good to go.

            Show
            nlust Nate Lust added a comment - I know this is probably not your change, but I question the choice of binned as the variable name at line https://github.com/lsst/obs_subaru/commit/f5fb626d2f40e647766c3ce09d93e9e3f597b8ed#diff-a371bdde1303aa2ed64bfec4eefc16e8R410 especially as it follows the variable binning. I think something like binnedImage or something would be more appropriate, but I don't think changing it is a requirement for merging. Other than that I think it looks good to go.
            Hide
            swinbank John Swinbank added a comment -

            Thanks. I agreed with your comment, tweaked the code appropriately, and pushed to master.

            Show
            swinbank John Swinbank added a comment - Thanks. I agreed with your comment, tweaked the code appropriately, and pushed to master.

              People

              • Assignee:
                swinbank John Swinbank
                Reporter:
                swinbank John Swinbank
                Reviewers:
                Nate Lust
                Watchers:
                John Swinbank, Nate Lust
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel