Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-4370

Migrate testdata for DECam from disk to git-lfs

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_decam
    • Labels:
      None

      Description

      There is a package full with test data for the obs_decam. It is an eups package currently, but not a git repository. I would like to migrate that into our hosted git-lfs so the obs_decam package can be built by Jenkins. J Matt Peterson [X] I'm hoping you would be willing to handle this for me. If not I can find somebody else. Thanks!

        Attachments

          Issue Links

            Activity

            Hide
            jmatt J Matt Peterson [X] (Inactive) added a comment -

            I moved the lfs configuration file (.gitconfig) to the first commit.

            Show
            jmatt J Matt Peterson [X] (Inactive) added a comment - I moved the lfs configuration file (.gitconfig) to the first commit.
            Hide
            hchiang2 Hsin-Fang Chiang added a comment -

            I installed git-lfs on my local machine, and now files are good and obs_decam tests pass.

            It's not yet working for me on lsst-dev yet, but I think that's my own user stupidness and I need to get educated.

            There were some conversations about git-lfs documentations in HipChat DM room this morning, Joshua Hoblitt may tell you more.

            Show
            hchiang2 Hsin-Fang Chiang added a comment - I installed git-lfs on my local machine, and now files are good and obs_decam tests pass. It's not yet working for me on lsst-dev yet, but I think that's my own user stupidness and I need to get educated. There were some conversations about git-lfs documentations in HipChat DM room this morning, Joshua Hoblitt may tell you more.
            Hide
            hchiang2 Hsin-Fang Chiang added a comment -

            I tried again and report that the obs_decam tests are passed on lsst-dev as well.

            My problem was that I needed to do git lfs init before cloning the repo. The repo I cloned before init is incorrect and stays incorrect.

            Show
            hchiang2 Hsin-Fang Chiang added a comment - I tried again and report that the obs_decam tests are passed on lsst-dev as well. My problem was that I needed to do git lfs init before cloning the repo. The repo I cloned before init is incorrect and stays incorrect.
            Hide
            krughoff Simon Krughoff added a comment -

            Looks good. I didn't try pushing, but I did clone it and everything seemed to work fine.

            Show
            krughoff Simon Krughoff added a comment - Looks good. I didn't try pushing, but I did clone it and everything seemed to work fine.
            Hide
            jmatt J Matt Peterson [X] (Inactive) added a comment -

            Complete.

            Show
            jmatt J Matt Peterson [X] (Inactive) added a comment - Complete.

              People

              • Assignee:
                jmatt J Matt Peterson [X] (Inactive)
                Reporter:
                krughoff Simon Krughoff
                Reviewers:
                Hsin-Fang Chiang, Simon Krughoff
                Watchers:
                Hsin-Fang Chiang, J Matt Peterson [X] (Inactive), Simon Krughoff, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel