Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-4947

Buildbot fails in afw on a pthread_creat issue

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: buildbot
    • Labels:
      None
    • Team:
      SQuaRE

      Description

      Upon running buildbot on branch DM-4692, which built successfully on Jenkins, I have twice received failures in afw. One of the cases is:

      :::::  [2016-01-28T23:38:27.571221Z] Failed test output:
      :::::  [2016-01-28T23:38:27.577021Z] tests/convolve.py
      :::::  [2016-01-28T23:38:27.577036Z] 
      :::::  [2016-01-28T23:38:27.577062Z] OpenBLAS: pthread_creat error in blas_thread_init function. Error code:11
      :::::  [2016-01-28T23:38:27.577254Z] The following tests failed:
      :::::  [2016-01-28T23:38:27.579376Z] /nfs/home/lsstsw/build/afw/tests/.tests/convolve.py.failed
      :::::  [2016-01-28T23:38:27.579479Z] 1 tests failed
      :::::  [2016-01-28T23:38:27.580101Z] scons: *** [checkTestStatus] Error 1
      :::::  [2016-01-28T23:38:27.584614Z] scons: building terminated because of errors.
      

      The other failure occurred in a different test but still with pthread_creat involved. Russell Owen believes that this is related to a similar problem that he saw on a UW machine involving process limits being exceeded. He can describe the issue better than I can.

      The full output is available at http://lsst-buildx.ncsa.illinois.edu:8010/builders/DM_stack/builds/9320/steps/shell/logs/stdio.

        Attachments

          Issue Links

            Activity

            Hide
            rowen Russell Owen added a comment -

            This appears to be the same problem as DM-4734, which Mario handled in eups as: https://github.com/RobertLuptonTheGood/eups/issues/58

            Perhaps the Buildbot system needs to be updated to the new eups?

            Show
            rowen Russell Owen added a comment - This appears to be the same problem as DM-4734 , which Mario handled in eups as: https://github.com/RobertLuptonTheGood/eups/issues/58 Perhaps the Buildbot system needs to be updated to the new eups?
            Hide
            tjenness Tim Jenness added a comment -

            Was a duplicate.

            Show
            tjenness Tim Jenness added a comment - Was a duplicate.

              People

              Assignee:
              frossie Frossie Economou
              Reporter:
              ctslater Colin Slater
              Watchers:
              Colin Slater, Mario Juric, Russell Owen, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.