Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-4960

LSST vs. HSC stack comparison: PSF estimation

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      5
    • Sprint:
      Science Pipelines DM-W16-6, DRP W16-7, DRP X16-1, DRP X16-2
    • Team:
      Data Release Production

      Description

      In order to determine the cause of the output differences between single frame processing runs of the same data using the LSST vs. HSC stacks (see figures attached to DM-4730), a detailed look at some of the image characterization steps is required. This ticket involves a detailed investigation of the initial PSF estimation including:

      LSST vs. HSC stack runs:
      • a comparison of the initial object detection (will likely involve looking at the initial background estimate as well as the specific assignment of footprints)
      • which objects are selected as PSF candidates
      • the initial PSF model (as a function of position)

        Attachments

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment - - edited


            This plot shows a comparison between the icMatches selected as calibration objects in the HSC vs. LSST stacks. Clearly, the LSST stack selects fewer candidates (about 75% of those selected by the HSC stack) and tends to avoid CCD edges, particularly around the outer edge of the focal plane (but seemingly on the inner edge of a given ccd?).

            There does not appear to be any particular bias against magnitude in this plot, but a closer examination reveals that LSST allows matches to brighter magnitudes: to ~13.4 I-mag compared to HSC's 14.6 apparent limit for this visit. Conversely, HSC allows for fainter selection: ~21.4 compared to ~21.2 for LSST.

            swinbank John Swinbank added a comment -

            Bob Armstrong has agreed to take this on while Lauren MacArthur is away. Thanks Bob!

            rearmstr Bob Armstrong added a comment -

            My initial comparison between PSF measurements did not look very good. I compared the ellipticities and sizes of the stars and psf model between matching objects in HSC vs. LSST. Here is a difference in e1 for the stars used in measuring the psf on visit 1322:

            This shows a large difference between the two, which was puzzling because I verified that the images themselves were nearly identical. Also, the rms of the residuals from both LSST and HSC were the same size. So each thought it was accurately reconstructing a good model of the psf. The discrepancy was not as bad for other visits like 1226:

            I believe the difference here is due to using a different initial psf model that is used to measure the centroids of stars that are input into psfex. In HSC, the initial psf is a Gaussian of fwhm=5.88 pixels. In the new LSST framework, the default settings do two iterations of finding the psf model, where the second iteration uses the estimate from the first. If the actual seeing is smaller than 5.88 then on the second iteration the centroids can shift. Here is the difference between the sdss x and y centroids for visit 1322, where fwhm=3.1.

            If you fix the number of iterations to 1, so the same size psf is used, then the ellipticity differences are much smaller (note the change in scale):

            This can also explain why some visits did not look too bad. If the psf width was close to the initial HSC width then the discrepancy was smaller which was the case for visit 1226.

            rearmstr Bob Armstrong added a comment - - edited

            Things are starting now to look reasonable. I have had to make the following changes to get these results:

            • change Approx=True and binSize=128 in background estimation
            • Set initial fwhm of PSF to 5.88
            • modify how SdssShape chooses it's footprint. There was a one pixel offset in the center and extent.
            • Turn off growing the footprints when setting the detection mask because LSST uses a different algorithm. I'm still not sure I understand why we grow the mask when we don't grow the footprints.
            • Rotate CCD's to match geometry.
            • Tried to feed LSST exactly the same PSF stars as HSC. Some CCD's in LSST miss a one or two PSF stars for some reason.

            Here are the differences in the e1 and size of the stars:

            Now for the PSF model:

            These differences are coming from using slightly different input stars.
            Here is the PSF flux:

            rearmstr Bob Armstrong added a comment -

            I have verified that things look good on a number of visits. I will now close this issue.


              People

              • Assignee:
                rearmstr Bob Armstrong
                Reporter:
                lauren Lauren MacArthur
                Watchers:
                Bob Armstrong, John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel