Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-4998

Fix rotation for isr in obs_subaru

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_subaru
    • Labels:
      None

      Description

      Approximately half of the HSC CCDs are rotated 180 deg with respect to the others. Two others have 90 deg rotations and another two have 270 deg rotations (see HSC CCD layout) . The raw images for the rotated CCDs thus need to be rotated to match the rotation of their associated calibration frames prior to applying the corrections. This is accomplished by rotating the exposure using the rotated context manager function in obs_subaru's isr.py and the nQuarter specification in the policy file for each CCD. Currently, rotated uses afw's rotateImageBy90 (which apparently rotates in a counter-clockwise direction) to rotated the exposure by 4 - nQuarter turns. This turns out to be the wrong rotation for the odd nQuarter CCDs as shown here:

      top left = raw exposure as read in
      top right = flatfield exposure as read in
      bottom left = incorrectly rotated raw exposure prior to flatfield correction

        Attachments

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment -

            Bob, could you have a look at this? I have confirmed the fix for all rotations and show an example of the fix for ccd 100 here (left panel is with the fix, right is without)

            rearmstr Bob Armstrong added a comment -

            I'm fine with these changes, given that, as we talked about last week, it is only a temporary solution to make things agree between HSC and LSST.

            lauren Lauren MacArthur added a comment -

            I think you meant to say "Review Complete" (as opposed to "Done").

            lauren Lauren MacArthur added a comment -

            For completeness' sake, since obs_subaru is now built as part of CI in Jenkins, I ran a build, which was successful. Merged to master.


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                lauren Lauren MacArthur
                Reviewers:
                Bob Armstrong
                Watchers:
                Bob Armstrong, John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: