Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5021

Stack in lsst-dev:/lsst/stack is broken

    Details

    • Templates:
    • Team:
      SQuaRE

      Description

      Viz:

      [swinbank@lsst-dev ~]$ source /lsst/stack/loadLSST.sh
      [swinbank@lsst-dev ~]$ setup -t b1894 lsst_apps
      [swinbank@lsst-dev ~]$ eups list -s lsst_apps
      python    11.0+98       b1894 setup
      [swinbank@lsst-dev ~]$ python -c'import lsst.utils'
      RuntimeError: module compiled against API version a but this version of numpy is 9
      Traceback (most recent call last):
        File "<string>", line 1, in <module>
        File "/home/lsstsw/stack/Linux64/utils/2015_10.0-3-g530cd83+11/python/lsst/utils/__init__.py", line 23, in <module>
          from utilsLib import *
        File "/home/lsstsw/stack/Linux64/utils/2015_10.0-3-g530cd83+11/python/lsst/utils/utilsLib.py", line 34, in <module>
          _utilsLib = swig_import_helper()
        File "/home/lsstsw/stack/Linux64/utils/2015_10.0-3-g530cd83+11/python/lsst/utils/utilsLib.py", line 30, in swig_import_helper
          _mod = imp.load_module('_utilsLib', fp, pathname, description)
      ImportError: numpy.core.multiarray failed to import
      

      (b1894 being the latest weekly at time of writing).

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  frossie Frossie Economou
                  Reporter:
                  swinbank John Swinbank
                  Watchers:
                  John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Tim Jenness
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Summary Panel