Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5044

Please add getDimensions method to Psf

    Details

    • Type: Improvement
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw
    • Labels:
      None
    • Team:
      Data Release Production

      Description

      At the moment it appears that the only way to obtain the dimensions of a PSF is to call psf.computeImage().getDimensions(). I would like a more direct method that doesn't require creating the image, such as psf.getDimensions()

        Attachments

          Issue Links

            Activity

            rowen Russell Owen added a comment -

            Paul Price points out that analytic PSFs have no native dimensions, but computeImage still works on them, so some kind of dimension could be returned. Perhaps a name such as getDefaultDimensions or getImageDimensions would make more sense.

            jbosch Jim Bosch added a comment -

            Do you need something that returns the same dimensions regardless of the position? I think one of the difficulties in implementing this is that it's not necessarily constant for CoaddPsf and WarpedPsf, because there the image size depends on the Wcs transformations applied to the Psf. On that note, if a position-dependent dimension is acceptable, I think we'd need to add similar dimension-predicting logic to the image warping routines to implement it for {{Psf}}s.

            rowen Russell Owen added a comment - - edited

            I think point-specific dimensions are fine. What I want is the same result as computeImage([point]).getDimensions(), where point is optional.

            jbosch Jim Bosch added a comment -

            Yusra AlSayyad, have you recently made this ticket obsolete?

            yusra Yusra AlSayyad added a comment -

            Yes, I consider this a duplicate of DM-8175


              People

              • Assignee:
                Unassigned
                Reporter:
                rowen Russell Owen
                Watchers:
                Jim Bosch, John Swinbank, Russell Owen, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel