Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5179

miniconda2 eups package fails to install on OS X

    Details

      Description

      The miniconda2 eups package attempts to install the relevant conda packages by downloading a list from the lsstsw repository. This fails for the same reason that lsstsw fails in DM-5178 in that the list of packages is not OS-specific. This means that newinstall.sh does not work any more on OS X.

        Attachments

          Issue Links

            Activity

            Hide
            jhoblitt Joshua Hoblitt added a comment -

            Changes to miniconda2 to pickup the per platform conda packages lists introduced in DM-5178 build under jenkins: https://ci.lsst.codes/job/stack-os-matrix/9294/

            Show
            jhoblitt Joshua Hoblitt added a comment - Changes to miniconda2 to pickup the per platform conda packages lists introduced in DM-5178 build under jenkins: https://ci.lsst.codes/job/stack-os-matrix/9294/
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            Merged. Tagged as 3.19.0.lsst4

            Show
            jhoblitt Joshua Hoblitt added a comment - Merged. Tagged as 3.19.0.lsst4
            Hide
            jhoblitt Joshua Hoblitt added a comment -
            Show
            jhoblitt Joshua Hoblitt added a comment - Tag looks good: https://ci.lsst.codes/job/stack-os-matrix/9295/
            Hide
            jhoblitt Joshua Hoblitt added a comment -
            Show
            jhoblitt Joshua Hoblitt added a comment - Published from b1961 https://ci.lsst.codes/job/run-publish/3/console
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            newinstall.sh was failing to distrib install the current version of lsst. Publishing lsst-2016_01.0-8-g0fc2317+2 from b1962 seems to have fixed that issue but now sconsUtils is failing.

            Show
            jhoblitt Joshua Hoblitt added a comment - newinstall.sh was failing to distrib install the current version of lsst . Publishing lsst-2016_01.0-8-g0fc2317+2 from b1962 seems to have fixed that issue but now sconsUtils is failing.
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            The issue seems to be that the version of gcc in the default travis linux container is 4.6. I'm surprised this wasn't failing before but the current version of sconsUtils [properly] blows up on it.

            Show
            jhoblitt Joshua Hoblitt added a comment - The issue seems to be that the version of gcc in the default travis linux container is 4.6. I'm surprised this wasn't failing before but the current version of sconsUtils [properly] blows up on it.
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            I've got travis working with the beta trusty image and I've added clang into the matrix as well.

            The current vresion of newinstall.sh has been published to https://sw.lsstcorp.org/eupspkg/newinstall.sh

            Show
            jhoblitt Joshua Hoblitt added a comment - I've got travis working with the beta trusty image and I've added clang into the matrix as well. The current vresion of newinstall.sh has been published to https://sw.lsstcorp.org/eupspkg/newinstall.sh

              People

              • Assignee:
                jhoblitt Joshua Hoblitt
                Reporter:
                tjenness Tim Jenness
                Watchers:
                Joshua Hoblitt, Peter Yoachim, Scott Daniel, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel