Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5368

Use modern TAP package declarations for all EUPS third party packages

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      0.5
    • Team:
      Architecture

      Description

      In DM-4670 the TAP-ness of the packages was declared using a .tap_package file. The modern fix is to use a $TAP_PACKAGE environment variable in the eupspkg.cfg.sh file. This is how pyyaml was implemented.

        Attachments

          Issue Links

            Activity

            Hide
            tjenness Tim Jenness added a comment -

            Minor change to add explicit eupspkg.cfg.sh file.

            Show
            tjenness Tim Jenness added a comment - Minor change to add explicit eupspkg.cfg.sh file.
            Hide
            ktl Kian-Tat Lim added a comment -

            Looks OK to me, given that we're not removing .tap_package yet.

            Show
            ktl Kian-Tat Lim added a comment - Looks OK to me, given that we're not removing .tap_package yet.

              People

              Assignee:
              tjenness Tim Jenness
              Reporter:
              tjenness Tim Jenness
              Reviewers:
              Mario Juric
              Watchers:
              Kian-Tat Lim, Mario Juric, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins Builds

                  No builds found.