Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5411

lsstsw can't find cairo 1.12.18.6 in osx-64 conda channel

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Team:
      SQuaRE

      Description

      I sat down to do a fresh lsstsw install today and failed with the following message:

      Python 2.7.11 :: Continuum Analytics, Inc.
      creating default environment...
      installation finished.
      Fetching package metadata: ....
      Error: No packages found in current osx-64 channels matching: cairo 1.12.18 6
       
      You can search for this package on anaconda.org with
       
          anaconda search -t conda cairo 1.12.18 6
       
      You may need to install the anaconda-client command line client with
       
          conda install anaconda-client
      

      FWIW, I actually don't really want to use the miniconda install at all. I'd rather just use my Python. So this problem isn't a current blocker as I worked around this by

      touch miniconda/.deployed
      

      and commenting out the # export PATH="$LSSTSW/miniconda/bin:$PATH" line in bin/setup.sh.

        Attachments

          Issue Links

            Activity

            Hide
            tjenness Tim Jenness added a comment -

            Duplicate of DM-5178.

            Show
            tjenness Tim Jenness added a comment - Duplicate of DM-5178 .

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              wmwood-vasey Michael Wood-Vasey [X] (Inactive)
              Watchers:
              Michael Wood-Vasey [X] (Inactive), Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: