Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5587

daf_persistence fails to build due to mariadbclient not finding openssl libraries

    XMLWordPrintable

Details

    • Bug
    • Status: Invalid
    • Resolution: Done
    • None
    • mariadb
    • None
    • SQuaRE

    Description

      When mariadbclient builds, it finds the openssl libraries in either miniconda or anaconda (or possibly other versions of openssl libraries anywhere on the system).
      However, when mariadbclient attempts to run later (such as when building daf_persistence), it can no longer find the libraries it used to build itself.
      Mario tells me it has to do with the libraries being linked into mariadbclient using 'rpath', but then rpath not being expanded somewhere in the files associated with mariadbclient .. in conda-build, these rpaths are expanded to the full values so everything works (and maybe this would be a solution - to make eups expand these rpath values, but then he kind of frowned).

      Anyway - this is a problem for users attempting to install the stack. The current answer appears to be "tell users to install openssl" but ..
      On redhat, even after doing 'yum install openssl' and 'yum install openssl-devel', the yum installed libraries were not used by mariadbclient (probably because they were version 1.0.1 instead of 1.0.0, which is what our mariadbclient is looking for).

      Attachments

        Issue Links

          Activity

            tjenness Tim Jenness added a comment -

            Marking this as a duplicate of DM-5170.

            tjenness Tim Jenness added a comment - Marking this as a duplicate of DM-5170 .

            People

              Unassigned Unassigned
              ljones Lynne Jones
              Lynne Jones, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.