Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5871

RuntimeError : dictionary changed size during iteration

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ci_hsc
    • Labels:
      None
    • Team:
      Data Release Production

      Description

      The following kind of error is sometimes observed in Jenkins:

      [2016-04-27T00:44:00.573318Z] scons: *** [.scons/sfm-903346-6] RuntimeError : dictionary changed size during iteration
      [2016-04-27T00:44:00.573449Z] Traceback (most recent call last):
      [2016-04-27T00:44:00.573500Z]   File "/home/build0/lsstsw/stack/Linux64/scons/2.3.5/lib/scons/SCons/Action.py", line 1063, in execute
      [2016-04-27T00:44:00.573582Z]     result = self.execfunction(target=target, source=rsources, env=env)
      [2016-04-27T00:44:00.573626Z]   File "/home/build0/lsstsw/build/ci_hsc/python/lsst/ci/hsc/validate.py", line 136, in scons
      [2016-04-27T00:44:00.573766Z]     return self.run(*args, **kwargs)
      [2016-04-27T00:44:00.573810Z]   File "/home/build0/lsstsw/build/ci_hsc/python/lsst/ci/hsc/validate.py", line 117, in run
      [2016-04-27T00:44:00.573829Z]     self.validateDataset(dataId, ds)
      [2016-04-27T00:44:00.573873Z]   File "/home/build0/lsstsw/build/ci_hsc/python/lsst/ci/hsc/validate.py", line 90, in validateDataset
      [2016-04-27T00:44:00.573988Z]     self.assertTrue("%s readable (%s)" % (dataset, data.__class__), data is not None)
      [2016-04-27T00:44:00.574054Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/readProxy.py", line 41, in __getattribute__
      [2016-04-27T00:44:00.574075Z]     subject = oga(self, '__subject__')
      [2016-04-27T00:44:00.574153Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/readProxy.py", line 136, in __subject__
      [2016-04-27T00:44:00.574252Z]     set_cache(self, get_callback(self)())
      [2016-04-27T00:44:00.574316Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/butler.py", line 365, in <lambda>
      [2016-04-27T00:44:00.574397Z]     callback = lambda: self._read(location)
      [2016-04-27T00:44:00.574458Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/butler.py", line 455, in _read
      [2016-04-27T00:44:00.574513Z]     results = location.repository.read(location)
      [2016-04-27T00:44:00.574573Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/repository.py", line 346, in read
      [2016-04-27T00:44:00.574720Z]     return self._access.read(butlerLocation)
      [2016-04-27T00:44:00.574782Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/access.py", line 125, in read
      [2016-04-27T00:44:00.574810Z]     return self.storage.read(butlerLocation=butlerLocation)
      [2016-04-27T00:44:00.574870Z]   File "/home/build0/lsstsw/stack/Linux64/daf_persistence/2016_01.0-8-geb625e2+1/python/lsst/daf/persistence/posixStorage.py", line 258, in read
      [2016-04-27T00:44:00.574886Z]     finalItem = pythonType()
      [2016-04-27T00:44:00.574941Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/config.py", line 473, in __new__
      [2016-04-27T00:44:00.575036Z]     field.__set__(instance, field.default, at=at+[field.source], label="default")
      [2016-04-27T00:44:00.575160Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/configurableField.py", line 216, in __set__
      [2016-04-27T00:44:00.575392Z]     oldValue.update(__at=at, __label=label, **value._storage)
      [2016-04-27T00:44:00.575451Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/config.py", line 513, in update
      [2016-04-27T00:44:00.575475Z]     field.__set__(self, value, at=at, label=label)
      [2016-04-27T00:44:00.575534Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/configurableField.py", line 211, in __set__
      [2016-04-27T00:44:00.575562Z]     oldValue.update(__at=at, __label=label, **value._storage)
      [2016-04-27T00:44:00.575617Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/config.py", line 513, in update
      [2016-04-27T00:44:00.575641Z]     field.__set__(self, value, at=at, label=label)
      [2016-04-27T00:44:00.575700Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/configurableField.py", line 211, in __set__
      [2016-04-27T00:44:00.575728Z]     oldValue.update(__at=at, __label=label, **value._storage)
      [2016-04-27T00:44:00.575781Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/config.py", line 513, in update
      [2016-04-27T00:44:00.575805Z]     field.__set__(self, value, at=at, label=label)
      [2016-04-27T00:44:00.575864Z]   File "/home/build0/lsstsw/stack/Linux64/pex_config/2016_01.0-1-g6fbf654+1/python/lsst/pex/config/configChoiceField.py", line 330, in __set__
      [2016-04-27T00:44:00.575882Z]     for k,v  in value.iteritems():
      [2016-04-27T00:44:00.575920Z]   File "/home/build0/lsstsw/miniconda/lib/python2.7/_abcoll.py", line 405, in iteritems
      [2016-04-27T00:44:00.576530Z]     for key in self:
      [2016-04-27T00:44:00.576564Z] RuntimeError: dictionary changed size during iteration
      

        Attachments

          Issue Links

            Activity

            price Paul Price added a comment -

            Duplicate of DM-5821.


              People

              • Assignee:
                price Paul Price
                Reporter:
                price Paul Price
                Watchers:
                Paul Price
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel