Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-5933

Replace jointcal.StarSelector with meas_algorithms.starSelector

    Details

    • Story Points:
      2
    • Sprint:
      Alert Production X16 - 5, Alert Production F16 - 6, Alert Production F16 - 7
    • Team:
      Alert Production

      Description

      jointcal has its own custom star selector. This should be removed and replaced with a star selector based on meas_algorithms.starSelector. A good choice might be meas_algorithms.objectSizeStarSelector.

        Attachments

          Issue Links

            Activity

            Hide
            Parejkoj John Parejko added a comment -

            Thanks for the reviews. jointcal branch now merged to master.

            I too am unhappy about the code duplication, but I'd much rather have it work now for either case and sort out a proper solution to the contiguity question.

            Show
            Parejkoj John Parejko added a comment - Thanks for the reviews. jointcal branch now merged to master. I too am unhappy about the code duplication, but I'd much rather have it work now for either case and sort out a proper solution to the contiguity question.
            Hide
            nlust Nate Lust added a comment -

            I too would like a resolution to the code duplication and contiguous catalog, but that is outside the scope of this work I think. I only have two minor comments on the ticket, otherwise the code looks fine.

            Show
            nlust Nate Lust added a comment - I too would like a resolution to the code duplication and contiguous catalog, but that is outside the scope of this work I think. I only have two minor comments on the ticket, otherwise the code looks fine.
            Hide
            rowen Russell Owen added a comment -

            I am unhappy about the code duplication and would rather require a contiguous catalog. I think we can get away with that because objectSize star selector requires it. However, I admit that is a change.

            Show
            rowen Russell Owen added a comment - I am unhappy about the code duplication and would rather require a contiguous catalog. I think we can get away with that because objectSize star selector requires it. However, I admit that is a change.
            Hide
            sullivan Ian Sullivan added a comment -

            The changes in meas_algorithms are straightforward, so that package is ready to go. If the code duplication caused by keeping both vectorized and non-vectorized versions of functions could be removed, that would be best, but that decision is beyond the scope of this ticket.

            Show
            sullivan Ian Sullivan added a comment - The changes in meas_algorithms are straightforward, so that package is ready to go. If the code duplication caused by keeping both vectorized and non-vectorized versions of functions could be removed, that would be best, but that decision is beyond the scope of this ticket.
            Hide
            Parejkoj John Parejko added a comment -

            Nate: please review the jointcal pull request (Ian's doing the meas_algorithms one).

            Show
            Parejkoj John Parejko added a comment - Nate: please review the jointcal pull request (Ian's doing the meas_algorithms one).

              People

              • Assignee:
                Parejkoj John Parejko
                Reporter:
                Parejkoj John Parejko
                Reviewers:
                Ian Sullivan, Nate Lust
                Watchers:
                Ian Sullivan, John Parejko, Nate Lust, Robert Lupton, Russell Owen, Simon Krughoff
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel