Looks fine. Suggested minor changes.
One overall comment though is that I think the RegistryField syntax as used for this purpose is highly confusing (and ugly). The simple test case already demonstrates this and I expect it to be far worse in real code. Especially now that there are two ways of specifying subtasks rather than just one. But I realise that this decision has already been made in
RFC-183. Moreover, given that this was effectively already supported I reckon it is better to have it tested and documented