Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6161

Add unit test for IsrTask

    Details

    • Type: Improvement
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ip_isr

      Description

      ip_isr has many unit tests, but none tests IsrTask. I suggest adding such a task, likely using the data in obs_test

        Attachments

          Issue Links

            Activity

            Parejkoj John Parejko added a comment -

            A useful refactor to simplify testing isrTask.run(), would be to have the stuff inside the for amp in ccd: live in a do_amp() method. do_amp() can then be tested separately.

            czw Christopher Waters added a comment -

            Closing as a duplicate of DM-15683

            czw Christopher Waters added a comment -

            Marking invalid, as DM-15683 is subsuming this work (and that will eventually be marked "Done").


              People

              • Assignee:
                krughoff Simon Krughoff
                Reporter:
                rowen Russell Owen
                Watchers:
                Christopher Waters, John Parejko, Russell Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel