Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6463

Please provide how-to-reproduce instructions for LSST/HSC comparison epics

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      DRP F16-1, DRP F16-2, DRP F16-3, DRP F16-4
    • Team:
      Data Release Production

      Description

      For all the stories describing comparisons between HSC and LSST results (notably DM-5301 and DM-5827), please provide instructions describing the steps to reproduce the comparison. In particular, include:

      • A list of any tweaks that had to be applied to the code;
      • Non-default configuration options;
      • Exactly which comparisons were made.

        Attachments

          Issue Links

            Activity

            rearmstr Bob Armstrong added a comment -

            These are the list of changes that I made to make the LSST and HSC stacks to produce exactly the same results. Since I am recording this after the fact, some these changes are included in DM-6815 and some of these have been incorporated from different tickets.

            • rotate the appropriate CCD's for LSST to use the HSC calibrations.
            • initial FWHM of the Gaussian PSF is larger for HSC.
            • set useApprox=True for LSST background estimation.
            • use the same bin size for background estimation.
            • make sure the same stars are chosen by LSST. I had to write a new algorithm to just use the output from HSC.
            • make sure to choose the same aperture for photometric calibration and PSF estimation.
            • for LSST sdss shape chooses a slightly different footprint. See computeAdaptiveMomentsBBox in SdssShape.cc.
            • changes in BackgroundMI::doGetImage for LSST

              People

              • Assignee:
                rearmstr Bob Armstrong
                Reporter:
                swinbank John Swinbank
                Watchers:
                Bob Armstrong, John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel