Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6491

Investigate offset in baseline zeropoint between LSST vs. HSC stack reductions for some HSC visits

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      DM-6490 reports on an offset between the calibration zeropoints between HSC vs. LSST processCcd.py runs. Here we report another, additional, offset seen in certain HSC visits. It is not seen in the figures shown in DM-6490 for visit 1322. However, here attach the same figures for visit 19696, run with identical setups/configs for both stacks as in DM-6490, where we see an additional offset in the "common ZP" figures (i.e. all fluxes have been scaled the same zp=33.0 for comparison).

      A best guess at present is that the calibration frames are different between the HSC and LSST stacks for the timeframe of this visit; e.g. were the inputs ingested exactly the same for both sets? Did the bug in regards to flagging on the flats noted in DM-5124:

      I found a difference in the codes doing the statistics: the HSC code uses a hard-coded mask ignore list of DETECTED only, while the LSST code uses a configurable mask ignore list that defaults to DETECTED,BAD (and the default isn't overridden). This produces a large difference on CCDs with bad amps (e.g., ccd=9). There's a smaller difference on ccd=49 because the number of BAD pixels is smaller. Also note that the scaling of one CCD (like ccd=9) can affect others because we force the normalisations to correspond to that which we get from solving the system of M exposures of N CCDs.

      have a greater impact on these calibs?

      Please investigate the cause of this offset.

        Attachments

          Issue Links

            Activity

            rearmstr Bob Armstrong added a comment -

            I have run processCcd with both LSST and HSC for two different vists: 1322 and 19696. I did not apply the aperture corrections or the zeropoint as determined from the calibration stage. All magnitudes that I looked at had a global offset that was independent of spatiail position.

            Here are the comparsisons for visit 1322 where the offset is ~ -0.003:


            There is still something strange going on in CCD 9 where there is a bad amp. This probably needs further investigation.

            The comparisons for 19696 are:

            The offset is larger here, but the same for psf and gaussian magnitudes.

            This is consistent with the difference being caused by differences in the calibration frames. DM-5301 has similar comparisons, but was processed when both HSC and LSST used the same set of calibration frames. You can see that there is no offset there, again leading to the conclusion that the offset here is caused by the calibrations.

            rearmstr Bob Armstrong added a comment -

            These offsets are not a big concern as they will be taken out via the photometric calibration stage. I am closing this issue.


              People

              • Assignee:
                rearmstr Bob Armstrong
                Reporter:
                lauren Lauren MacArthur
                Watchers:
                Bob Armstrong, John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel