Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6647

Adapt qa analysis script to apply corrections measured by meas_mosaic

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_tasks
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      DRP F16-1, DRP F16-2, DRP F16-3, DRP F16-4, DRP F16-5
    • Team:
      Data Release Production

      Description

      DM-2674 involves getting HSC's meas_mosaic working with the LSST stack. This issue consists of adapting the analysis.py script of DM-4393 & DM-4730 to (optionally) apply the astrometric and photometric solutions derived running meas_mosaic to the individual visits before comparison. This is useful in general and is specifically useful in comparing the meas_mosaic results between the HSC and LSST stacks.

        Attachments

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment -

            Bob, would you mind giving this a quick sanity check? Plots demonstrating the application of the meas_mosaic solution are shown in DM-2674. I've adapted the code to allow for a selection between three "calibrations" when plotting:

            Can choose between:
                doApplyUberCal: Apply meas_mosaic solution to catalogs
                doApplyCalexpZp: Apply FLUXMAG0 zeropoint to sources?
                                 Ignored if doApplyUberCal is True
                If above are both False, apply a common zeropoint of 33.0 mag.
            

            A label "zp: XXX" at the lower left of the plots has been included to identify which of the above was applied in making the plot.

            The analysis script and various accommodations to obs_subaru (namely the schema alias mapper between the LSST and HSC stacks and some additional datasets) are in u/lauren/DM-6647 branches in pipe_tasks and obs_subaru, respectively, for anyone who wants to have a look, but note that there is no intention of merging anything as of yet.

            swinbank John Swinbank added a comment -

            Hey Lauren MacArthur, Bob Armstrong – I just realised that this has been in review since July! Can you provide a status update, please?

            lauren Lauren MacArthur added a comment -

            No change on my end, except perhaps to point out that the script now lives in its own repo at https://github.com/lsst-dm/pipe_analysis

            swinbank John Swinbank added a comment -
            rearmstr Bob Armstrong added a comment -

            I guess this slipped by me. I just have a few minor comments

            It seems a little clunky to have to set the values of two parameters if I want to use the calexp zeropoint or the common zeropoint. Not a big deal, though.

            Have you thought about always making plots with a common zeropoint in addition to ones using either the calexp or meas_mosaic zeropoint. That way, if you see a problem you can know if the issue is in the calibration or the basic reduction. Otherwise, with the current settings, you will need to run the code twice.

            lauren Lauren MacArthur added a comment -

            Good points. I could default to always making just the PSF comparison plots with the common ZP (since we only really need one set to see any issues and I'm trying not to add to the enormous number of plots being generated!). That way it could just be a single config parameter doApplyUberCal to choose between the meas_mosaic (doApplyUberCal = True) and calexp (doApplyUberCal = False) calibrations.

            lauren Lauren MacArthur added a comment -

            The above has been implemented. The updated scripts can be found on the u/lauren/working branch in pipe_analysis. This will be merged to the master branch following some further edits for the coadd processing (DM-6588).


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                lauren Lauren MacArthur
                Reviewers:
                Bob Armstrong
                Watchers:
                Bob Armstrong, John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel