Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6651

Move new reference loader so meas_astrom can use it and perform some cleanup

    Details

      Description

      The new reference object loader code lives in pipe_tasks, which means it cannot be directly used by code in meas_astrom. This will hamper separating astrometry.net out of meas_astrom, because unit tests need reference catalogs and meas_astrom cannot depend on pipe_tasks.

      Also, I'd like to take a cleanup pass on the module names, so the new code is easier to find, and improve the unit tests.

        Attachments

          Issue Links

            Activity

            Hide
            rowen Russell Owen added a comment -

            I moved all of the index reference reading code from pipe_tasks to meas_algorithms except for the binary script that runs the loader, since meas_algorithms has no bin.src directory and I'm reluctant to add one to such a low-level package. Still, that leaves it in a non-obvious location so perhaps that is a mistake.

            I also did some minor renaming:

            • renaming indexReferenceTask to ingestIndexReferenceTask
            • hoisted that task up into lsst.meas.algorithms to simplify .paf files
            • moved each catalog loader task into its own module with a more descriptive name

            obs_test needed a trivial update due to the new location of IngestIndexedReferenceConfig

            Show
            rowen Russell Owen added a comment - I moved all of the index reference reading code from pipe_tasks to meas_algorithms except for the binary script that runs the loader, since meas_algorithms has no bin.src directory and I'm reluctant to add one to such a low-level package. Still, that leaves it in a non-obvious location so perhaps that is a mistake. I also did some minor renaming: renaming indexReferenceTask to ingestIndexReferenceTask hoisted that task up into lsst.meas.algorithms to simplify .paf files moved each catalog loader task into its own module with a more descriptive name obs_test needed a trivial update due to the new location of IngestIndexedReferenceConfig
            Hide
            krughoff Simon Krughoff added a comment -

            Looks fine. Free to merge.

            Show
            krughoff Simon Krughoff added a comment - Looks fine. Free to merge.

              People

              • Assignee:
                rowen Russell Owen
                Reporter:
                rowen Russell Owen
                Reviewers:
                Simon Krughoff
                Watchers:
                Russell Owen, Simon Krughoff
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel