Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-6817

Compare HSC and LSST processing of RC dataset

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      8
    • Sprint:
      DRP F16-2, DRP F16-3, DRP F16-4, DRP F16-5, DRP F16-6
    • Team:
      Data Release Production

      Description

      Using the script enhanced in DM-6588, compare HSC and LSST (DM-6816) processing of the RC dataset.

        Attachments

        1. compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-psfMagHist.png
          compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-psfMagHist.png
          232 kB
        2. compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-sky-gals.png
          compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-sky-gals.png
          259 kB
        3. compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-sky-stars.png
          compare-t0-HSC-I-diff_base_CircularApertureFlux_12_0-sky-stars.png
          277 kB
        4. compare-t0-HSC-I-diff_modelfit_CModel-psfMagHist.png
          compare-t0-HSC-I-diff_modelfit_CModel-psfMagHist.png
          245 kB
        5. compare-t0-HSC-I-diff_modelfit_CModel-sky-gals.png
          compare-t0-HSC-I-diff_modelfit_CModel-sky-gals.png
          262 kB
        6. compare-t0-HSC-I-diff_modelfit_CModel-sky-stars.png
          compare-t0-HSC-I-diff_modelfit_CModel-sky-stars.png
          281 kB
        7. compare-t0-HSC-I-diff_x-psfMagHist.png
          compare-t0-HSC-I-diff_x-psfMagHist.png
          231 kB
        8. compare-t0-HSC-I-diff_x-sky-gals.png
          compare-t0-HSC-I-diff_x-sky-gals.png
          255 kB
        9. compare-t0-HSC-I-diff_x-sky-stars.png
          compare-t0-HSC-I-diff_x-sky-stars.png
          271 kB
        10. compare-t0-HSC-I-diff_y-psfMagHist.png
          compare-t0-HSC-I-diff_y-psfMagHist.png
          239 kB
        11. compare-t0-HSC-I-diff_y-sky-gals.png
          compare-t0-HSC-I-diff_y-sky-gals.png
          264 kB
        12. compare-t0-HSC-I-diff_y-sky-stars.png
          compare-t0-HSC-I-diff_y-sky-stars.png
          280 kB
        13. compareVisit-v1228-diff_base_CircularApertureFlux_12_0-psfMagHist.png
          compareVisit-v1228-diff_base_CircularApertureFlux_12_0-psfMagHist.png
          198 kB
        14. compareVisit-v1228-diff_base_CircularApertureFlux_12_0-sky-gals.png
          compareVisit-v1228-diff_base_CircularApertureFlux_12_0-sky-gals.png
          234 kB
        15. compareVisit-v1228-diff_base_CircularApertureFlux_12_0-sky-stars.png
          compareVisit-v1228-diff_base_CircularApertureFlux_12_0-sky-stars.png
          288 kB
        16. compareVisit-v1228-diff_base_GaussianFlux-psfMagHist.png
          compareVisit-v1228-diff_base_GaussianFlux-psfMagHist.png
          186 kB
        17. compareVisit-v1228-diff_base_GaussianFlux-sky-gals.png
          compareVisit-v1228-diff_base_GaussianFlux-sky-gals.png
          237 kB
        18. compareVisit-v1228-diff_base_GaussianFlux-sky-stars.png
          compareVisit-v1228-diff_base_GaussianFlux-sky-stars.png
          292 kB
        19. compareVisit-v1228-diff_x-psfMagHist.png
          compareVisit-v1228-diff_x-psfMagHist.png
          158 kB
        20. compareVisit-v1228-diff_x-sky-gals.png
          compareVisit-v1228-diff_x-sky-gals.png
          233 kB
        21. compareVisit-v1228-diff_x-sky-stars.png
          compareVisit-v1228-diff_x-sky-stars.png
          278 kB
        22. compareVisit-v1228-diff_y-psfMagHist.png
          compareVisit-v1228-diff_y-psfMagHist.png
          188 kB
        23. compareVisit-v1228-diff_y-sky-gals.png
          compareVisit-v1228-diff_y-sky-gals.png
          240 kB
        24. compareVisit-v1228-diff_y-sky-stars.png
          compareVisit-v1228-diff_y-sky-stars.png
          290 kB
        25. compareVisit-v1228-hsmTrace_-psfMagHist.png
          compareVisit-v1228-hsmTrace_-psfMagHist.png
          92 kB
        26. compareVisit-v1228-hsmTrace_-sky-stars.png
          compareVisit-v1228-hsmTrace_-sky-stars.png
          244 kB
        27. hscCompareCoaddAnalysis-DM-6816-cosmos-all_shortSum.txt
          8 kB
        28. hscCompareCoaddAnalysis-DM-6816-cosmos-all_sum.txt
          8 kB
        29. hscCompareCoaddAnalysis-DM-6816-wide-all_shortSum.txt
          9 kB
        30. hscCompareCoaddAnalysis-DM-6816-wide-all_sum.txt
          13 kB
        31. hscCompareVisitAnalysis-DM-6816-cosmos-all_shortSum.txt
          20 kB
        32. hscCompareVisitAnalysis-DM-6816-cosmos-all_sum.txt
          174 kB
        33. hscCompareVisitAnalysis-DM-6816-wide-all_shortSum.txt
          17 kB
        34. hscCompareVisitAnalysis-DM-6816-wide-all_sum.txt
          90 kB

          Issue Links

            Activity

            lauren Lauren MacArthur added a comment -

            The attached txt files provide direct comparison statistics of matched sources between the LSST and HSC RC dataset runs. The *_sum.txt show the per visit/tract results, whereas the *_shortSum.txt show just the averages over the visit/tract entries.

            All of the diagnostics shown have accompanying figures. Several example plots are also attached.

            lauren Lauren MacArthur added a comment -

            While most of the global statistics look quite good, closer scrutiny of these figures and those in DM-6818 have revealed some regressions in the LSST stack. Of particular note, the CModel vs. psf plot on DM-6818 (plot-t0-HSC-I-mag_modelfit_CModel-psfMagHist.png) reveals a large density of objects that have likely been misclassified as galaxies (namely the strip of red objects just below the threshold for the star/galaxy classification) and a "bump" at bright magnitudes in the "stars". The latter seems to be rooted in the psf modeling at the single frame stage, as indicated in the direct size comparison plot shown here:

            An investigation into the causes of these issues will be conducted as part of the DM-8299 epic.

            swinbank John Swinbank added a comment -

            Filed DM-8532 & DM-8533 to investigate the issues described above.

            swinbank John Swinbank added a comment -

            Given that this comparison has been performed and follow-up issues filed, I think we can regard this as done.

            Lauren MacArthur, if there are further issues resulting from this comparison, please file them as part of DM-8299.

            swinbank John Swinbank added a comment -

            Chatted to Lauren; agreed that we don't expect anything more on this ticket.


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                swinbank John Swinbank
                Watchers:
                John Swinbank, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel