Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-688

meas_base exception handling not consistent with meas_algorithms

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_base
    • Labels:

      Description

      The current meas_base framework does not allow algorithms to both set values in their measurement records and set the general failure flag, since on failure, the Result object is not returned to the framework code.

      SdssShape in particular is written to set values in its record even when certain errors occur. For that reason, when one of these errors orccurs, it can be written either to have all its record values set except for the general error flag, or to only have the general error flag set.

      I chose for testing purposes to not set the general error flag and instead test for failure using the disjunction of the other flags, but that is not a good long term solution.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -

            Closing this as a duplicate of DM-464


              People

              Assignee:
              jbosch Jim Bosch
              Reporter:
              pgee Perry Gee
              Watchers:
              Jim Bosch, Perry Gee, Robert Lupton
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.