Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-7323

Please rename DbStorage.next to something less confusing

    XMLWordPrintable

Details

    • Improvement
    • Status: Invalid
    • Resolution: Done
    • None
    • daf_persistence
    • None
    • Data Access and Database

    Description

      lsst.daf.persistence.DbStorage has a method named next that does not act like a python iterator. This makes the Python interface confusing. Please rename the method to something else (preferably both in C++ and Python).

      Thanks to tjenness for discovering this.

      Attachments

        Issue Links

          Activity

            People

              npease Nate Pease [X] (Inactive)
              rowen Russell Owen
              Kian-Tat Lim, Nate Pease [X] (Inactive), Russell Owen, Steve Pietrowicz, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.