Details
-
Type:
Epic
-
Status: Done
-
Resolution: Done
-
Fix Version/s: None
-
Component/s: obs_cfht, obs_decam, obs_lsstSim, obs_sdss, obs_subaru, obs_test
-
Labels:
-
Epic Name:obs testing framework
-
Story Points:40
-
WBS:02C.03.05
-
Team:Alert Production
-
Cycle:Fall 2016
Description
The various obs* package test cases should derive from a set of parent TestCases, so that they all trivially have the same testing functionality. obs_decam has more tests written for it than most of the other packages, but most of those tests could be lifted into some higher package, with the obs_decam test looking like, e.g.
...boilerplate...
|
class GetIdTestCase(obs_test_helper.tests.IdTestCase):
|
def setUp(self):
|
self.mapper = DecamMapper(root=".")
|
super(GetIdTestCase, self).setUp()
|
self.dataId = {'visit'=229388, 'ccdnum'=13, 'filter'='z'}
|
self.result_id = 22938813'
|
...boilerplate...
|
with all of the test* methods living obs_test_helper.tests.IdTestCase. This is just a sketch of a design, but I think it would both simplify deploying new obs packages and allow us to almost trivially improve testing coverage in the existing packages.
Attachments
Issue Links
- relates to
-
DM-4096 Please unify the various scripts for displaying cameras
- Won't Fix
-
DM-7909 mapper.validate should raise ValueError on non-integer visits
- Won't Fix
-
RFC-228 Rename obs_test to obs_example
- Withdrawn
-
RFC-230 Rename daf_butlerUtils to obs_base
- Implemented
-
DM-6333 Define ownership and plan work for obs_* packages, ISR, and CameraMapper
- Done
-
DM-7049 Move patch/tract and config mapping definitions to daf_butlerUtils
- Done
Key | Summary | Story Points | Assignee | Status | |
---|---|---|---|---|---|
|
0.5 | John Parejko | Done | ||
|
8 | John Parejko | Done | ||
|
0.5 | John Parejko | Done | ||
|
4 | John Parejko | Done | ||
|
4 | Unassigned | Won't Fix |
Is it just tests that have lots of code duplication? I was under the impression that many of the obs_ packages share a lot of boiler plate that could be refactored into an obs_generic package.