Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-7756

Port pipe_drivers to Python 3

    Details

    • Story Points:
      0.5
    • Sprint:
      Alert Production S17 - 2
    • Team:
      Alert Production

      Description

      pipe_drivers needs to be converted to python 3.

        Attachments

          Issue Links

            Activity

            tjenness Tim Jenness created issue -
            tjenness Tim Jenness made changes -
            Field Original Value New Value
            Link This issue relates to DM-6179 [ DM-6179 ]
            tjenness Tim Jenness made changes -
            Remote Link This issue links to "Page (Confluence)" [ 14320 ]
            rowen Russell Owen made changes -
            Remote Link This issue links to "Page (Confluence)" [ 14320 ] This issue links to "Page (Confluence)" [ 14320 ]
            rowen Russell Owen made changes -
            Remote Link This issue links to "Page (Confluence)" [ 14320 ] This issue links to "Page (Confluence)" [ 14320 ]
            swinbank John Swinbank made changes -
            Assignee John Swinbank [ swinbank ]
            swinbank John Swinbank made changes -
            Epic Link DM-7318 [ 26403 ]
            swinbank John Swinbank made changes -
            Story Points 2
            swinbank John Swinbank made changes -
            Epic Link DM-7318 [ 26403 ] DM-8136 [ 27591 ]
            tjenness Tim Jenness made changes -
            Remote Link This issue links to "Page (Confluence)" [ 14320 ] This issue links to "Page (Confluence)" [ 14320 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7047 [ DM-7047 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7245 [ DM-7245 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7292 [ DM-7292 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7152 [ DM-7152 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7021 [ DM-7021 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7264 [ DM-7264 ]
            tjenness Tim Jenness made changes -
            Link This issue is blocked by DM-7243 [ DM-7243 ]
            tjenness Tim Jenness made changes -
            Watchers John Swinbank, Tim Jenness [ John Swinbank, Tim Jenness ] John Swinbank, Paul Price, Tim Jenness [ John Swinbank, Paul Price, Tim Jenness ]
            tjenness Tim Jenness added a comment - - edited

            I've had a quick look at pipe_drivers and it looks like the port to python 3 will be pretty easy: a couple of old-style exceptions, some use of itervalues(), other minor tweaks.

            Currently lsst_distrib works fine regardless because there are no tests in pipe_drivers to fail (DM-9059).

            tjenness Tim Jenness made changes -
            Link This issue relates to DM-9059 [ DM-9059 ]
            rowen Russell Owen made changes -
            Assignee Russell Owen [ rowen ]
            rowen Russell Owen made changes -
            Story Points 2 0.5
            rowen Russell Owen made changes -
            Sprint Alert Production S17 - 2 [ 361 ]
            Team Data Release Production [ 10301 ] Alert Production [ 10300 ]
            rowen Russell Owen added a comment - - edited

            I want to do this before the fixes for pybind11 DM-8462

            rowen Russell Owen made changes -
            Status To Do [ 10001 ] In Progress [ 3 ]
            rowen Russell Owen made changes -
            Link This issue blocks DM-8462 [ DM-8462 ]
            rowen Russell Owen added a comment -

            A standard port. Pretty easy. One minor point: I ran autopep8 without the default line length because we are switching to 80 character lines. However, I was not religious about fixing any remaining lines that were longer. Call it a start in that direction.

            rowen Russell Owen made changes -
            Reviewers Paul Price [ price ]
            Status In Progress [ 3 ] In Review [ 10004 ]
            tjenness Tim Jenness added a comment -

            Can you make a pull request? There are some extra list() calls that you don't need.

            rowen Russell Owen added a comment -

            I removed all unnecessary list(...) and .keys(). I also found two more instances of foo = lambda that I turned into normal functions and added one # noqa to hide a linter warning caused by standard_library.install_aliases() being needed before some module-level import statements.

            tjenness Tim Jenness added a comment -

            The lack of tests is a worry but these cleanups look fine to me. I'm happy to call this reviewed if Paul Price is too busy.

            rowen Russell Owen made changes -
            Reviewers Paul Price [ price ] Tim Jenness [ tjenness ]
            rowen Russell Owen added a comment -

            Marking "reviewed" as per Tim Jenness's comments above. Note that I also ran constructBias.py successfully under python 2, so at least that did not get broken by these changes.

            rowen Russell Owen made changes -
            Status In Review [ 10004 ] Reviewed [ 10101 ]
            rowen Russell Owen added a comment -

            Rebased to clean up the commit history a bit and merged.

            rowen Russell Owen made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]

              People

              • Assignee:
                rowen Russell Owen
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Tim Jenness
                Watchers:
                John Swinbank, Paul Price, Russell Owen, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel