Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-8044

Default local background subtraction to False for safe coadd clipping

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_tasks
    • Labels:
      None
    • Story Points:
      0.5
    • Epic Link:
    • Sprint:
      DRP F16-6
    • Team:
      Data Release Production

      Description

      In RFC-212 we adopted turning on the "junk suppression" temporary local background subtraction by default: SourceDetectionConfig.doTempLocalBackground=True. Since the safe clipping coadd assembly (introduced in DM-2915) also performs object detection, this had the effect of turning on the junk suppression background there too. The safe clipping algorithm was designed and tuned with no extra background estimations, thus doTempLocalBackground should default to False for that task.

        Attachments

          Issue Links

            Activity

            swinbank John Swinbank added a comment -

            Right: to check the demo you'd need to build against Python 3 yourself. I think we maybe ought to do that, except that I bet the demo will just fail to run with Py 3 so it's not worth the effort.

            lauren Lauren MacArthur added a comment -

            Ah, yes, I suppose that would be the way to go as of now. Just to be sure, are you advising that I don't bother checking the demo against py3?

            swinbank John Swinbank added a comment -

            I satisfied myself that nobody has actually run the demo with Py3. Therefore, I think not bothering to check against it is fine.

            tjenness Tim Jenness added a comment -

            The problem is we can't run the demo on Jenkins because running the demo has been conflated with running lsst_ci.

            lauren Lauren MacArthur added a comment -

            Merged to master.


              People

              • Assignee:
                lauren Lauren MacArthur
                Reporter:
                lauren Lauren MacArthur
                Reviewers:
                John Swinbank
                Watchers:
                John Swinbank, Lauren MacArthur, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: