Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-812

Installation of boost (with new build system) fails if user has Enthought Canopy

    Details

    • Templates:
    • Team:
      SQuaRE

      Description

      Alex Kim reported a failure of boost to build when attempting to install lsst_sims (via eups distrib install lsst_sims -t sims).
      This is on Mavericks, with clang 5.1.
      I think the problem is the same as described here:
      https://github.com/GalSim-developers/GalSim/issues/506
      since after applying the workaround, he reports that boost builds.

      On the issue page linked above, there is a description of how to edit the build files so that scons can find the python files appropriately. Is this something that can or should be folded back into the LSST installer?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ljones Lynne Jones
                Watchers:
                Jim Bosch, John Swinbank, Lynne Jones, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel