Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-8131

Investigate different combinations of cmake and other lsstsw dependencies

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The goal in these attempts were to align the conda-lsst environment and requirements with lsstsw. This addresses the "It works for me" issue with demonstrating build issues.

      There appeared to be a problem with how cmake built mariadb and mariadbclient. See DM-8035 and DM-7340. In the end Conda's cmake version 3.3.x was used to build mariadb along with the changes in DM-8035 and patching conda-lsst to use MariaDB/MariaDBClient 10.1.18 instead 10.1.11.

        Attachments

          Issue Links

            Activity

            Hide
            jmatt J Matt Peterson [X] (Inactive) added a comment -

            The Conda v12.1 (semantic version 0.12.1) binaries have been successfully created. The repository for this release is: http://conda.lsst.codes/stack/0.12.1

            Show
            jmatt J Matt Peterson [X] (Inactive) added a comment - The Conda v12.1 (semantic version 0.12.1) binaries have been successfully created. The repository for this release is: http://conda.lsst.codes/stack/0.12.1

              People

              • Assignee:
                jmatt J Matt Peterson [X] (Inactive)
                Reporter:
                jmatt J Matt Peterson [X] (Inactive)
                Reviewers:
                Frossie Economou
                Watchers:
                Frossie Economou, J Matt Peterson [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel