Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-8221

Inconsistency in forced schema catalogs

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_base, pipe_tasks
    • Labels:
      None
    • Story Points:
      2
    • Epic Link:
    • Sprint:
      DRP F16-6
    • Team:
      Data Release Production

      Description

      Nicolas Chotard has discovered an inconsistency between the deepCoadd_forced_src catalogs and their accompanying _schema dataset in some processed Megacam data; one of these (I forget which) has a few additional fields, which mostly seem related to aperture correction.

      First step is to add a test for this in pipe_task's testCoadds.py; if that doesn't fail, we can try to reproduce in ci_hsc, and if that fails I'll ask for more details about the specific dataset.

        Attachments

          Activity

          jbosch Jim Bosch added a comment -

          Russell Owen, could you take a look at this? The vast majority of the changes are new tests and test support code, along with a one-line fix for the actual bug in meas_base.

          The meas_base and pipe_tasks branches are branched from and diffed against DM-8210, as the rely on some code there that hasn't been merged to master yet. I'll rebase this ticket once that happens.

          jbosch Jim Bosch added a comment -

          DM-8210 has now been merged to master, but I'm not going to rebase this ticket's branches until after review, since I can't change the base of the PR diff.

          rowen Russell Owen added a comment -

          A very nice enhancement to the tests, in addition to fixing that bug. I had a few trivial requests on github.

          jbosch Jim Bosch added a comment -

          Merged to master.


            People

            • Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Reviewers:
              Russell Owen
              Watchers:
              Jim Bosch, Russell Owen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: