Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-8260

Remove scisql dependency from datarel

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: datarel
    • Labels:
      None
    • Templates:
    • Story Points:
      0.125
    • Team:
      SQuaRE

      Description

      datarel is a deprecated package but is still there as a root for the documentation system. It optionally depends on scisql and that is the only package blocking Python 3 for lsst_distrib. I propose we remove the optional dependency and allow lsst_distrib to work with Python 3.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Tim Jenness
                Watchers:
                Joshua Hoblitt, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel