Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-933

Photometric calibration uses a column "flux" not the specified filter unless a colour term is active

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_algorithms
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      DRP X16-2, DRP X16-3
    • Team:
      Data Release Production

      Description

      The photometric calibration code uses a field "flux" in the reference catalog to impose a magnitude limit. If a colour term is specified, it uses the primary and secondary filters to calculate the reference magnitude, but if there is no colour term it uses the column labelled "flux" and ignores the filtername.

      Please change the code so that "flux" is ignored, and the flux associated with filterName is used.

        Attachments

          Activity

          swinbank John Swinbank added a comment - - edited

          I think this was resolved as part of DM-1576. See (what I surmise is) the relevant code here, and the changes I have been able to make as part of DM-4125 (push coming up in a moment).

          Can you please confirm if this resolves the issue for you?

          swinbank John Swinbank added a comment -

          Robert Lupton – I propose to close this issue as Done. Do you object?

          rhl Robert Lupton added a comment -

          Not proven. If you're confident, sure – but I have no independent evidence for or against the accused.

          lauren Lauren MacArthur added a comment -

          I believe I have confirmed John Swinbank's assertion above that this is no longer an issue by doing the following.

          Run processCcd.py using --config calibrate.photoCal.applyColorTerms=False calibrate.photoCal.colorterms.data={} and adding some print statements here:
          https://github.com/lsst/pipe_tasks/blob/master/python/lsst/pipe/tasks/photoCal.py#L526

          I get the following:

          log from processCcd.py

          processCcd.calibrate.photoCal: Not applying color terms because config.applyColorTerms is False
          

          Print statements in photoCal.py

          filtername =  i
          fluxFieldList =  ['i_flux']
          len(self.config.colorterms.data) =  0
          self.config.colorterms.data =  {}
          

          Thus, even though no color term is supplied nor applied, the appropriate flux field is used.
          Is this satisfactory proof?

          lauren Lauren MacArthur added a comment -

          John Swinbank, would you mind giving this a look (it appears Robert Lupton is too busy)?

          swinbank John Swinbank added a comment -

          I pronounce this reviewed. And done.

          swinbank John Swinbank added a comment -

          Thanks Lauren!


            People

            • Assignee:
              lauren Lauren MacArthur
              Reporter:
              rhl Robert Lupton
              Reviewers:
              John Swinbank
              Watchers:
              John Swinbank, Lauren MacArthur, Robert Lupton
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel