Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-9330

Uniqueness of metric name

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The issue was raised by Jonathan Sick during the code review of DM-9034 and led to this ticket.

       
               if vdrp_measurement_doc['value'] is None:
                   continue
      +        if vdrp_measurement_doc['metric']['name'] not in registered_metrics:
      +            metrics.append(shim_metric_definition(vdrp_measurement_doc))
         
      
      

      @jsick:
      Is it possible for a metric to appear multiple times in this list? Like, if there's multiple AM1 measurements in different bands, or multiple measurements against different specifications of a metric, then couldn't we have duplicates here?

      @afausti:
      That's a good point. In this implementation the metric name is unique so if there is already an AM1 registered it would not pick another AM1 with a different specification.

      I see the problem when a metric, say AD1, depends on another metric specification, in this case AF1. We end up with three measurements of AD1 for each AF1 specification level, right?

      I think if a metric has a different parameter or specification it should be named differently, so that we can identify each metric uniquely by its name, or perhaps have another mechanism like a composite primary key based on the metric name and specification? we should think on how to display the metric measurements in this situation too.

        Attachments

          Activity

          afausti Angelo Fausti added a comment -

          Metric names are unique by design in lsst.verify now.

          frossie Frossie Economou added a comment -

          Let's enforce uniqueness of metric names eventually through metric registration and police ourselves in the meanwhile


            People

            • Assignee:
              afausti Angelo Fausti
              Reporter:
              afausti Angelo Fausti
              Watchers:
              Angelo Fausti, Frossie Economou
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel