Fix Version/s: None
The names of various asserts in afw are outdated and should be modernized. The current names make tests more confusing to read and write.
Either change all current usage in all packages or (if that is too much work) write trivial variants that use the old names but print a deprecation warning.
DM-10096 Add unit test asserts for SpherePoint, SpherePointList and PointList
Implemented as part of