Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-9767

Building afw on clang results in warnings

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw

      Description

      Building afw on macOS 10.11 using clang 8.0.0 results in the following warnings:

      src/formatters/MaskFormatter.cc:112:16: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          if (typeid(*storage) == typeid(BoostStorage)) {
                     ^
      src/formatters/MaskFormatter.cc:119:21: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          else if (typeid(*storage) == typeid(FitsStorage)) {
                          ^
      src/formatters/MaskFormatter.cc:136:16: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          if (typeid(*storage) == typeid(BoostStorage)) {
                     ^
      src/formatters/MaskFormatter.cc:144:21: warning: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Wpotentially-evaluated-expression]
          else if (typeid(*storage) == typeid(FitsStorage)) {
                          ^
      4 warnings generated.
      

        Attachments

          Issue Links

            Activity

            rowen Russell Owen created issue -
            krzys Krzysztof Findeisen made changes -
            Field Original Value New Value
            Link This issue is child task of DM-10257 [ DM-10257 ]
            krzys Krzysztof Findeisen made changes -
            Resolution Done [ 10000 ]
            Status To Do [ 10001 ] Invalid [ 11005 ]
            krzys Krzysztof Findeisen added a comment -

            Partial duplicate of DM-10257, issue fixed there.


              People

              • Assignee:
                Unassigned
                Reporter:
                rowen Russell Owen
                Watchers:
                Jim Bosch, Krzysztof Findeisen, Robert Lupton, Russell Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel