We need to have two dataset names for coadd images: one for the raw coadd produced by assembleCoadd.py, and one for the background-subtracted coadd with detections identified produced by detectCoaddSources.py. The first is deepCoadd in both LSST and HSC, and is not in contention. The second is deepCoadd_calexp_det in LSST and deepCoadd_calexp in HSC. I think the LSST name originates from before HSC transitioned to a naming scheme that I think makes sense, and hence I think it's a bit confused, and unnecessarily long and clumsy. I would like to make the LSST naming scheme consistent with that of HSC because I think it's simpler, clearer, and more people have more experience with it. deepCoadd_calexp currently appears to be unused on the LSST side.
Now seems to be a good time to do this, before the multiband products become more widely used on the LSST side. The HSC port ticket
DM-5288 will do this work, including updating dataset names in the obs_* packages.