Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-226

Upgrade cmake to minimum version 2.8.12

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None

      Description

      The current effective minimum required cmake version is 2.8.11 (as installed on CentOS7).
      Strangely though CentOS6 comes with the newer cmake 2.8.12.

      Having cmake 2.8.12 as minimum version on all targets would unblock DM-4891 and enable upstream pybind11 cmake files to be used without modification.

      This RFC proposes to provide cmake 2.8.12 in case the system version is too old.
      We can do so either through conda or by other means if deemed better.

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  pschella Pim Schellart [X] (Inactive)
                  Reporter:
                  pschella Pim Schellart [X] (Inactive)
                  Watchers:
                  John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Pim Schellart [X] (Inactive), Tim Jenness
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Planned End:

                    Summary Panel