Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-230

Rename daf_butlerUtils to obs_base

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None

      Description

      It appears that most of the current contents of daf_butlerUtils would get moved into the obs_base package I've been working on and was going to RFC. Since there's not really a current need for an "astronomy butler interface layer" (what daf_butlerUtils was supposed to be), we can just rename it to obs_base and move the testing framework I'd been developing into it.

      Kian-Tat Lim has suggested that we may want a "butler_something" package in the future which may have some pieces of daf_persistence or obs_base moved into it, but since those components haven't been identified, and the packages that currently depend on daf_butlerUtils would likely not depend on that new package, we're better off renaming now and creating the new package later.

        Attachments

          Issue Links

            Activity

            Hide
            jbosch Jim Bosch added a comment -

            I suppose I'm mildly in favor, but mostly I just don't feel very strongly either way. obs_base seems like a nicer name that daf_butlerUtils, so it's just weighing the better name against the cost of disruption.

            Show
            jbosch Jim Bosch added a comment - I suppose I'm mildly in favor, but mostly I just don't feel very strongly either way. obs_base seems like a nicer name that daf_butlerUtils, so it's just weighing the better name against the cost of disruption.
            Hide
            ctslater Colin Slater added a comment -

            I like obs_base, since I can never remember daf_butlerUtils, and it's hard to know from the name what "*utils" specifically does.

            I also like CameraMapper living closer to obs than daf.

            Show
            ctslater Colin Slater added a comment - I like obs_base, since I can never remember daf_butlerUtils, and it's hard to know from the name what "*utils" specifically does. I also like CameraMapper living closer to obs than daf.
            Hide
            rowen Russell Owen added a comment -

            +1

            obs_base is being added in any case (for very good reasons). Most or all of the contents of daf_butlerUtils seem to fit well in obs_base, and will be easier to find there than in daf_butlerUtils. If something in daf_butlerUtils seems too low-level or non-obs-ish for obs_base then it could be moved to daf_base or similar.

            Show
            rowen Russell Owen added a comment - +1 obs_base is being added in any case (for very good reasons). Most or all of the contents of daf_butlerUtils seem to fit well in obs_base , and will be easier to find there than in daf_butlerUtils . If something in daf_butlerUtils seems too low-level or non-obs-ish for obs_base then it could be moved to daf_base or similar.
            Hide
            price Paul Price added a comment -

            I don't care, unless you break things.

            Show
            price Paul Price added a comment - I don't care, unless you break things.
            Hide
            ktl Kian-Tat Lim added a comment -

            Parts of CameraMapper need to be refactored out (later) so that they can support any Mapper, but I'm OK with this. (In the meantime, Nate Pease will have to muck with obs_base from time to time.)

            Show
            ktl Kian-Tat Lim added a comment - Parts of CameraMapper need to be refactored out (later) so that they can support any Mapper, but I'm OK with this. (In the meantime, Nate Pease will have to muck with obs_base from time to time.)
            Hide
            Parejkoj John Parejko added a comment -

            There appears to be agreement on this. Implementation ticket created in DM-7915, and I plan to get it done as soon as possible.

            Show
            Parejkoj John Parejko added a comment - There appears to be agreement on this. Implementation ticket created in DM-7915 , and I plan to get it done as soon as possible.
            Hide
            Parejkoj John Parejko added a comment -

            Make implementation tickets triggered-by.

            Show
            Parejkoj John Parejko added a comment - Make implementation tickets triggered-by.

              People

              • Assignee:
                Parejkoj John Parejko
                Reporter:
                Parejkoj John Parejko
                Watchers:
                Colin Slater, Jim Bosch, John Parejko, John Swinbank, Kian-Tat Lim, Paul Price, Russell Owen, Simon Krughoff, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Planned End:

                  Summary Panel