Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-25

Increase MaskPixel size from 16 to 32 bits

    XMLWordPrintable

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None
    • Location:
      this issue page

      Description

      We've found on HSC that we do need more than 16 mask planes, and hence it's almost certain that LSST will as well. We might as well make that change sooner than later.

      This will also make it a bit more important that we get FITS compression working (there is code to do this, but we don't know how recently we've used it).

        Attachments

          Issue Links

            Activity

            tjenness Tim Jenness added a comment -

            Can this RFC be closed?

            nlust Nate Lust added a comment -

            The work to increase the number of bits to 32 has been done, but the compression work has not.

            tjenness Tim Jenness added a comment -

            Please attach the compression ticket to this RFC then. It currently looks like all the work has been completed.

            swinbank John Swinbank added a comment -

            I don't see a statement on this RFC that implementing it requires compression. I think it's done.

            rhl Robert Lupton added a comment -

            I'm fine with closing this (hurrah!), but the implication was that we'd almost immediately get compression enabled as otherwise we have a significant regression (both in disk storage and possibly I/O rates). So can we make it a reasonably high priority?


              People

              Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Gregory Dubois-Felsmann, Jim Bosch, John Swinbank, Kian-Tat Lim, Mario Juric, Nate Lust, Robert Lupton, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Planned End: