Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-293

Specify minimum CentOS7 version as baseline

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None

      Description

      The definition of the baselined operating system is currently poorly defined.

      In the developer guide we state that lsst-dev01 is using the latest version of CentOS 7. In the pipelines installation instructions we state just that we officially test against CentOS 7.

      What we don't do is define this version. As part of RFC-226 we requested that our baselined version of cmake be updated to v2.8.12 but that RFC was withdrawn pending the release of CentOS 7-1611 in December 2016 (CentOS 6.8 already has a new enough cmake).

      Can we specify CentOS7-1611 as our minimum supported version of CentOS7? I understand that Joshua Hoblitt is working on updating the Jenkins system in DM-8402. Bill Glick what would be the impact at NCSA if we mandated CentOS7-1611 as the minimum CentOS7 supported version? Is that a reasonable request? Or should we work out alternative ways of getting cmake updated on CentOS7?

        Attachments

          Container Issues

            Issue Links

              Activity

                People

                • Assignee:
                  tjenness Tim Jenness
                  Reporter:
                  tjenness Tim Jenness
                  Watchers:
                  Bill Glick, Christopher Clausen, Jason Alt [X] (Inactive), Jeff Kantor, John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Pim Schellart [X] (Inactive), Tim Jenness
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  9 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Planned End:

                    Summary Panel