Currently, the "flux" fields in our source catalogs are actually "on-chip, post-ISR counts", instead of "calibrated fluxes". This causes two problems: users looking for calibrated counts don't reach the correct objects, and we don't have a good place to put calibrated fluxes. I propose that all of our *Flux_flux/*Flux_fluxSigma fields be renamed *Flux_instFlux/*Flux_instFluxSigma, which will allow us to add e.g. *Flux_flux and *Flux_mag fields to our source catalogs to hold post-calibrated fluxes (in Maggies) and magnitudes (Pogson). The DPDD says in section 3.3 "Fluxes and Magnitudes" that we will distribute "flux" in units of "maggies", so this new naming is consistent with that.
This developed while I was working on the new PhotoCalib object and I realized I'd inadvertantly overloaded the term "flux" in the code (sometimes meaning counts, sometimes calibrated flux). Some of this came from borrowing from the old Calib (where the term is very overloaded), and some from an attempt to get it right in the PhotoCalib code but then tripping over the input/output catalog field names.
We will also rename the InstFlux slot to GaussianFlux, and remove the InstMag slot.
In terms of work required, searching the stack (*.h, *.cc, *.py) found 111 matches in 33 files to Flux_flux, plus about 80 total matches in about 20 files (didn't compare overlap with the former) to several variations on + "_flux.
In terms of timing, implementing this would wait until Calib was removed from the stack and replaced by PhotoCalib (not yet scheduled, but likely within the next couple months).