Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-379

Update minimum versions of numpy, astropy and matplotlib after v14.0 is released

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None

      Description

      We currently state that the minimum supported versions of numpy, astropy and matplotlib are 1.5.1, 1.1.1 and 1.5.1 respectively. Now that version 2.x of astropy and matplotlib packages are easily available, on pypi and conda, it would seem to be a good time to move our minimum versions after we release v14.0. numpy is currently at v1.13.

      As discussed in https://community.lsst.org/t/what-is-the-backward-compatiblity-requirement-on-astropy-and-matplotlib/2139 there are some features of these packages that would be useful, and it would allow us to remove the font cache hack we use in the build system to prevent race conditions.

        Attachments

          Issue Links

            Activity

            tjenness Tim Jenness created issue -
            tjenness Tim Jenness made changes -
            Field Original Value New Value
            Link This issue relates to RFC-375 [ RFC-375 ]
            tjenness Tim Jenness made changes -
            Remote Link This issue links to "Community discussion (Web Link)" [ 15351 ]
            tjenness Tim Jenness made changes -
            Summary Update minimum versions of astropy and matplotlib after v14.0 is released Update minimum versions of numpy, astropy and matplotlib after v14.0 is released
            tjenness Tim Jenness made changes -
            Description We currently state that the minimum supported versions of astropy and matplotlib are 1.1.1 and 1.5.1 respectively. Now that version 2.x of both packages are easily available on pypi and conda, it would seem to be a good time to move our minimum versions after we release v14.0.

            As discussed in https://community.lsst.org/t/what-is-the-backward-compatiblity-requirement-on-astropy-and-matplotlib/2139 there are some features of these packages that would be useful, and it would allow us to remove the font cache hack we use in the build system to prevent race conditions.

            We currently state that the minimum supported versions of numpy, astropy and matplotlib are 1.5.1, 1.1.1 and 1.5.1 respectively. Now that version 2.x of astropy and matplotlib packages are easily available, on pypi and conda, it would seem to be a good time to move our minimum versions after we release v14.0. numpy is currently at v1.13.

            As discussed in https://community.lsst.org/t/what-is-the-backward-compatiblity-requirement-on-astropy-and-matplotlib/2139 there are some features of these packages that would be useful, and it would allow us to remove the font cache hack we use in the build system to prevent race conditions.

            tjenness Tim Jenness made changes -
            Link This issue is triggering DM-11727 [ DM-11727 ]
            tjenness Tim Jenness made changes -
            Status Proposed [ 10805 ] Adopted [ 10806 ]
            tjenness Tim Jenness made changes -
            Link This issue relates to RFC-382 [ RFC-382 ]
            tjenness Tim Jenness made changes -
            Resolution Done [ 10000 ]
            Status Adopted [ 10806 ] Implemented [ 11105 ]
            tjenness Tim Jenness made changes -
            Link This issue relates to RFC-584 [ RFC-584 ]

              People

              • Assignee:
                tjenness Tim Jenness
                Reporter:
                tjenness Tim Jenness
                Watchers:
                John Parejko, John Swinbank, Kian-Tat Lim, Lauren MacArthur, Lynne Jones, Michael Wood-Vasey, Simon Krughoff, Tim Jenness
              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Planned End:

                  Summary Panel