Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-424

Request approval of the LSST Data Facility Logical ITC Design document (LDM-129)

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM, TCT
    • Labels:

      Description

      This is a complete redrafting of LDM-129, the LSST Data Facility Logical Information Technology and Communications Design, originally titled the DM Infrastructure Design. We are now submitting a revised version for formal approval as informing the replan baseline.

      The version is available in the LDM-129 repository on DocuShare as the latest non-preferred version.

        Attachments

        1. LDM-129.docx
          1.17 MB
        2. LDM-129.docx
          1.18 MB
        3. LDM-129 Components.pdf
          26 kB
        4. LDM-129 Components.pdf
          26 kB
        5. LDM-129-review-20180117.docx
          988 kB
        6. LDM-129-RFC424-update.docx
          981 kB

          Issue Links

            Activity

            ktl Kian-Tat Lim added a comment -

            It is correct that all of the services that are part of the "L1" test stand and the prior "L1" enclaves are not directly related to Prompt Processing, but many of the ones listed in LDM-129 really are for Prompt Processing exclusively (i.e. I/O File System, Template Cache, Application Support File System).  I think it is still clearer to call the enclaves "Prompt" than "L1", because the Prompt data products (including raw images) are their primary purpose.  In LDM-148, I still refer to the "Level 1" Test Stand (with quotation marks), so that can stay.

            In section 2.2.4, the lsst-dev ancillary nodes in the "Relied-on ITC" are said to come from the NCSA Master Provisioning Enclave, presumably from the Kubernetes Commons component.  I thought that the virtual host software would be implemented using the NCSA Virtual Machine Hosting described in section 3.1.7.  Perhaps the idea is to use both, with machines taken from the MPE but managed using the VM Hosting facilities.

            I believe LDM-148 is generally consistent with the design presented here, although this design is at a lower level than LDM-148 in some areas (e.g. the Master Provisioning Enclaves say how the LDM-148 enclaves are to be provisioned) and at a higher level in others (e.g. LDM-148 breaks the "Data Backbone Enclave" down into two "Archive Enclaves").  If we change "L1" to "Prompt", I believe that all names that are actually for the same things will match.

             

            mbutler Michelle Butler added a comment -

            Tim Jenness I have completed all the edits above.  I have confirmed with Kian-Tat Lim that LDM-148 matches this document pretty well as KT says above.    I have uploaded the latest version here in this ticket.   I consider my self done with LDM-129 unless more edits are needed and put into this ticket.   

            Michelle 

            tjenness Tim Jenness added a comment -

            Wil O'Mullane I can upload this to Docushare (adding Michelle as a co-author) as soon as you approve the RFC.

            womullan Wil O'Mullane added a comment -

            ok lets get it in Docushare as preffered and yes add Michelle to the author list.

            tjenness Tim Jenness added a comment -

              People

              • Assignee:
                mbutler Michelle Butler
                Reporter:
                mgelman2 Margaret Gelman
                Watchers:
                Donald Petravick, Frossie Economou, Gregory Dubois-Felsmann, Jonathan Sick, Kian-Tat Lim, Margaret Gelman, Michelle Butler, Robert Lupton, Tim Jenness, Wil O'Mullane, Zeljko Ivezic
              • Votes:
                0 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Planned End:

                  Summary Panel