Details
-
Type:
RFC
-
Status: Implemented
-
Resolution: Done
-
Component/s: DM
-
Labels:None
-
Location:This ticket, or the Data Management chat room
Description
As part of DM-2635 I propose to make the following changes to the C++ API of the "utils" package:
Remove two functions we are not using anywhere:
- guessSvnVersion: this is clearly useless now that we use git
- stringToAny: we aren't using it, and it has no documentation
Rename lsst::utils::eups::productDir to lsst::utils::getPackageDir and remove the version argument. Note that the version argument has only one valid value, so it's never been useful. This would be the implementation of DM-2635.
A better solution would be to remove the use of productDir from the examples (passing the filename on the command line?), but it probably isn't worth doing as part of this issue.
The tests are similar:
tests/background.cc: afwdata_dir = lsst::utils::eups::productDir("afwdata");
tests/convolveGPU.cc: string dataDir = lsst::utils::eups::productDir("afwdata");
tests/statistics.cc: afwdata_dir = lsst::utils::eups::productDir("afwdata");
tests/testWarpGpu.cc: string dataDir = lsst::utils::eups::productDir("afwdata");
and we should probably remove some (do we really need C++ tests for things we test in python?) and convert the others to accept filenames from argv[], also as another issue.