As part of the ap_verify work we are writing a pipeline-agnostic framework for the code that actually computes metrics. The framework will provide code for computing metrics given an arbitrary (processed) repository as well as the ability to integrate said code into Gen 2 and Gen 3 pipelines. The system is being prototyped in
We'd like to put the new framework in its own lsst_distrib package to keep it independent of specific pipelines, the more abstract verify framework, or the metrics definitions in verify_metrics. We propose to keep with the current verify naming convention by calling the new package verify_measurements, but we understand that the term "measurement" is falling out of favor and are open to alternatives.