RFC-283 never quite finalized a name for the Task that generates the objects it renamed to Warp. Given the exact same arguments supplied in that RFC, and the discussion in DM-4634 (which was sadly closed as won't fix), we should rename the task to better match its outputs (and be less of a mouthful).
MakeWarpTask seems perfect: it makes warps.
It looks like this task is being reworked for butler gen3: this rename could happen as part of that, or just before it. There are only 90 references to makeCoaddTempExp in the stack (pipe_tasks, pipe_drivers, obs_decam/cfht/subaru, plus a couple lines in ci_hsc), so the change itself should be easy to make.