Uploaded image for project: 'Request For Comments'
  1. Request For Comments
  2. RFC-56

Upgrade minimum required gcc version to 4.8

    XMLWordPrintable

    Details

    • Type: RFC
    • Status: Implemented
    • Resolution: Done
    • Component/s: DM
    • Labels:
      None
    • Location:
      this issue page

      Description

      Our adoption of C++11 (and C++14 features) is held back by the very minimal (and occasionally incorrect) support for C++11 in gcc 4.4.

      Major long-term-support Linux distributions that ship with gcc 4.8 have now been out for about a year now (including RHEL/CentOS 7 and Ubuntu 14.04), so it may now be reasonable to expect users currently relying on gcc 4.4 to either upgrade their OS or bear the burden of installing a newer compiler.

      We could also consider providing eups distrib packages with newer compiler versions for those who need them (we do this on the HSC side).

      In any case, I don't think we can simply wait for OSes that ship gcc 4.4 to go away on their own; the lifespans of those distributions are simply too long. But if certain important users are already scheduled to upgrade in the near future anyway, it may be prudent to just wait for that ourselves.

        Attachments

          Issue Links

            Activity

            Hide
            rowen Russell Owen added a comment - - edited

            Our sysadmins at UW installed the following on a Scientific Linux release 6.6 (Carbon) machine and it worked just fine to build the LSST DM stack using "eups distrib install -t v10_1 lsst_apps":

            • devtoolset-3-toolchain
            • devtoolset-3-perftools
            • devtoolset-3-git "but not all it's extra bits"

            If you do adopt devtoolset-3 as the preferred alternative for older versions of linux then please do specify a reasonable subset. The whole package is so large that I think many sysadmins will be reluctant to install it.

            Show
            rowen Russell Owen added a comment - - edited Our sysadmins at UW installed the following on a Scientific Linux release 6.6 (Carbon) machine and it worked just fine to build the LSST DM stack using "eups distrib install -t v10_1 lsst_apps": devtoolset-3-toolchain devtoolset-3-perftools devtoolset-3-git "but not all it's extra bits" If you do adopt devtoolset-3 as the preferred alternative for older versions of linux then please do specify a reasonable subset. The whole package is so large that I think many sysadmins will be reluctant to install it.
            Hide
            tjenness Tim Jenness added a comment -

            Does this mean we have enough evidence to be able to close this RFC?

            Show
            tjenness Tim Jenness added a comment - Does this mean we have enough evidence to be able to close this RFC?
            Hide
            ktl Kian-Tat Lim added a comment -

            devtoolset-3 subpackages as identified by UW (preferred), eups distrib gcc, conda installation are all acceptable mechanisms for getting gcc 4.8 on RHEL6 and equivalents.

            Show
            ktl Kian-Tat Lim added a comment - devtoolset-3 subpackages as identified by UW (preferred), eups distrib gcc, conda installation are all acceptable mechanisms for getting gcc 4.8 on RHEL6 and equivalents.
            Hide
            bglick Bill Glick added a comment -

            The devtoolset-3 subpackages (devtoolset-3-toolchain, devtoolset-3-perftools, & devtoolset-3-git) have now been installed on the lsst-dev.ncsa.illinois.edu server. devtoolset-2 has been removed. These devtoolset-3 subpackages will be installed on all LSST developer systems managed at NCSA. Documentation of the usage of devtoolset-3 has also been updated at:
            https://confluence.lsstcorp.org/display/LDMDG/Developer+Tools+at+NCSA

            Show
            bglick Bill Glick added a comment - The devtoolset-3 subpackages (devtoolset-3-toolchain, devtoolset-3-perftools, & devtoolset-3-git) have now been installed on the lsst-dev.ncsa.illinois.edu server. devtoolset-2 has been removed. These devtoolset-3 subpackages will be installed on all LSST developer systems managed at NCSA. Documentation of the usage of devtoolset-3 has also been updated at: https://confluence.lsstcorp.org/display/LDMDG/Developer+Tools+at+NCSA
            Hide
            jhoblitt Joshua Hoblitt added a comment -

            devtoolset-3 has been enabled on buildbot on under jenkins on EL6 per DM-3597.

            Show
            jhoblitt Joshua Hoblitt added a comment - devtoolset-3 has been enabled on buildbot on under jenkins on EL6 per DM-3597 .

              People

              Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Bill Glick, Fabrice Jammes, Fritz Mueller, Frossie Economou, Jacek Becla, Jim Bosch, John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Mario Juric, Paul Price, Russell Owen, Simon Krughoff, Tim Jenness
              Votes:
              3 Vote for this issue
              Watchers:
              14 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Planned End: