There is an irritating inconsistency between how you specify configuration parameters on the command line (config.foo.bar) and in a configuration file (root.foo.bar). This is especially annoying when you use --show config to obtain the name, cut and paste the answer into a file, and are rewarded with:
error: cannot load config file 'ptfConfig.py': name 'config' is not defined
This RFC proposes that we adopt a consist naming convention. I prefer config everywhere, but (as Kian-Tat Lim points out) that's a slightly more complex change than adopting root everywhere. On the other hand, I think that adopting config is much clearer, and wouldn't tempt us to change the the pipe_base's -show config[=glob] option.
|Field||Original Value||New Value|
|Resolution||Done [ 10000 ]|
|Status||Proposed [ 10805 ]||Adopted [ 10806 ]|
|Status||Adopted [ 10806 ]||Implemented [ 11105 ]|